درود فراوان خدمت تمام دوستان. حتما شما هم مثل بنده صبح از خواب پا شدید و با بروزرسانی جدید ۴٫۶ وردپرس مواجه شدید و خیلی مشتاقانه این بروزرسانی رو انجام دادید و متاسفانه پس از اون بجای دریافت اطلاعات بروزرسانی، با صفحه سفید معروف به صفحه مرگ مواجه شدید!

متاسفانه یک مشکل امنیتی در این نسخه وجود داره و با نسخه های php هاست ها سازگار نیست.

راه حل چیه؟

حل مشکل Warning: ini_get_all() has been disabled for security reasons در بروزرسانی ۴٫۶ وردپرس

۱- ریستور بکاپ: در صورتی که بکاپ تازه ای از وب سایت خود دارید، ساده ترین راه ریستور کردن آن می باشد

۲- فعال یا غیرفعال کردن ini_get_all() در php شما: که باید به هاستینگ خود اطلاع دهید، اگر فعال هست غیرفعال و اگر غیرفعال هست فعال شود.

۳- آپدیت php هاست: برخی دوستان اعلام کردن که با بروزرسانی به نسخه ۵٫۶ یا بالاتر این مشکل را حل کردند. این موضوع در هاست های ما کمی پیچیده است زیرا اکثرا نسخه ۵٫۴ دارند و قابلیت بروزرسانی ندارند. این موضوع نیز باید از هاستینگ شما بررسی شود

۴- استفاده از نسخه بتا ۴٫۶ وردپرس: دقیقا کاری که بنده انجام دادم 🙂

۱- ابتدا این فایل را دانلود کنید: دانلود

۲- سپس در روت هاست خود یعنی جایی که فایل های wp-admin و wp-content و … وجود دارند

۳- پس از اون فایل را اکسترکت نمایید. اگر سوالی مبنی بر جایگزین شدن فایل ها(Replace) از شما پرسیده شد قبول کنید.

۴- وارد وردپرس خود شوید و دیگر بروزرسانی انجام ندهید تا نسخه جدیدتری اعلان شود

۵- فایلی که دانلود و آپلود کرده بودید را حذف کنید.

امیدوارم مشکلتون حل بشه

* با آرزوی موفقیت برای شما

آخرین نوشته ها

نوشته های مفید

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

Fill out this field
Fill out this field
لطفاً یک نشانی ایمیل معتبر بنویسید.

فهرست